Baseball for the Thinking Fan

Login | Register | Feedback

btf_logo
You are here > Home > Jim's Lab Notes > Discussion
Jim's Lab Notes
— Site News, Baseball Talk, and a Bunch of Other Stuff

Monday, May 24, 2010

Combating Spammers and Upgrades Update

The number of people joining solely to post Spam links on the site has been growing. To combat these parasites, member profiles are now only viewable to logged in members of the site. I’m also spending more time pruning the member rolls to remove users who join the site to place Spam links within the site’s content. I’ll soon be adding a “Report” link (similar to the link within Forum posts) to all comments to make it easier for people to let me know when they stumble upon Spam. I thank everyone who takes the time to help me remove Spam from the site.

I’m continuing work on improving the performance and reliability of the site. Although people have reported much faster page loads over the last week, there are still a few changes I need to make, which should significantly improve the performance and reliability of the site even further. To implement these changes, I will need to take the site down for maintenance a few more times over the next few weeks. I will post notices before each planned outage. I appreciate your patience during these times. 

Jim Furtado Posted: May 24, 2010 at 12:47 PM | 63 comment(s) Login to Bookmark
  Related News:

Reader Comments and Retorts

Go to end of page

Statements posted here are those of our readers and do not represent the BaseballThinkFactory. Names are provided by the poster and are not verified. We ask that posters follow our submission policy. Please report any inappropriate comments.

   1. Spivey Posted: May 24, 2010 at 01:23 PM (#3541175)
Thanks for everything you're doing to try to make this site even better.
   2. UCCF Posted: May 24, 2010 at 01:51 PM (#3541201)
I’ll soon be adding a “Report” link (similar to the link within Forum posts) to all comments to make it easier for people to let me know when they stumble upon Spam.

Will we also be using the "Report" link to "report" people who are acting like ######## in violation of the TOS? Or is it only for spam?
   3. Levi Stahl Posted: May 24, 2010 at 03:52 PM (#3541280)
Seconding Spivey: thanks, Jim. Your work is much appreciated.
   4. Hang down your head, Tom Foley Posted: May 24, 2010 at 04:59 PM (#3541368)
Spammers suck as hell.
   5. bob gee Posted: May 24, 2010 at 05:17 PM (#3541385)
+a lot.
   6. JC in DC Posted: May 24, 2010 at 08:43 PM (#3541638)
Spivey sucks. Remove him and improve the site!
   7. Best Dressed Chicken in Town Posted: May 24, 2010 at 09:16 PM (#3541662)
Will we also be using the "Report" link to "report" people who are acting like ######## in violation of the TOS?

No, only schoolmarms like you will.
   8. UCCF Posted: May 24, 2010 at 09:45 PM (#3541688)
Pretty tough talk coming from a chicken.
   9. Spivey Posted: May 24, 2010 at 09:47 PM (#3541690)
Spivey sucks. Remove him and improve the site!


Child please.
   10. Best Dressed Chicken in Town Posted: May 24, 2010 at 09:55 PM (#3541701)
Cluck cluck!
   11. The importance of being Ernest Riles Posted: May 24, 2010 at 10:54 PM (#3541754)
Great post. Your site may also be interested in Eagle Hands Laundry. If your eagles hands are dirty, we'll wash them clean!
   12. Bernal Diaz has an angel on his shoulder Posted: May 25, 2010 at 11:40 AM (#3542076)
Still waiting for my puppy....
   13. odds are meatwad is drunk Posted: May 25, 2010 at 11:50 AM (#3542079)
an im still waiting for a decent meal then again so are the students!
   14. GGC don't think it can get longer than a novella Posted: May 26, 2010 at 02:20 AM (#3543061)
Does this explain the weird emails supposedly coming from Repoz?
   15. Jim Furtado Posted: May 26, 2010 at 12:47 PM (#3543205)
Weird emails from Repoz?
   16. 1k5v3L Posted: May 26, 2010 at 01:55 PM (#3543245)
I believe Repoz's yahoo account has been hacked. A couple of days I received an email from it asking me to go to some website and purchase some items, no questions asked, satisfaction guaranteed, etc. Yahoo email accounts have been easy targets to hackers, as I've received similar emails from yahoo accounts of some other friends. My advice: get rid of your yahoo account.
   17. Lassus Posted: May 31, 2010 at 12:17 AM (#3546367)
Hey guys, can someone fix the game chatters? They've been stuck on the 27th since..... the 27th.
   18. Lassus Posted: May 31, 2010 at 12:13 PM (#3546460)
Bump, and repeat.
   19. Jim Furtado Posted: May 31, 2010 at 12:29 PM (#3546462)
I'm working on getting the Chimp back up and running. If he's not getting the job done today, I'll manually post the links.
   20. Jim Furtado Posted: May 31, 2010 at 01:20 PM (#3546475)
I've cleaned his cage and installed an automatic banana dispenser. The Chimp is back on the job!
   21. Honkie Kong Posted: May 31, 2010 at 02:25 PM (#3546495)
I have no idea if its designed behaviour, or some isolated issue with my browser, but the discussion threads in the newsblog don't load the hot topics for me anymore.

Figured this was as good a thread as any to kvetch about it. FWIW, I can see the hot topics for this blog on the right, which makes me think it might be part of the design to reduce server load?

EDIT : Now that I complained about it, it seems to be working properly! In 2 minutes! The lesson, whine and moan and ##### if you want to get things done

EDIT EDIT : On a re-read, it sounded like I was impugning Jim. Not at all. Just think it was an internet snafu. I like having this site to waste time on, and appreciate the efforts of the people behind the scenes who keep it up.
   22. Darren Posted: June 02, 2010 at 10:56 PM (#3548445)
Jim--

I no longer have a control panel for some reason. Is that a bug or a feature?
   23. bobm Posted: June 02, 2010 at 11:05 PM (#3548454)
I just got assigned 5 bookmarks randomly.
   24. ursus arctos Posted: June 02, 2010 at 11:39 PM (#3548478)
Yeah, the bookmarks appear to be highly volatile today.

I presume it is due to other work in progress, as they seem to settle down eventualy.
   25. vortex of dissipation Posted: June 03, 2010 at 12:03 AM (#3548489)
I posted an item on the newsblog today (on Reds rookie Mike Leake), but the block text from the article didn't show up on the newsblog main page. It did show up though, when I opened the link to the comments section, and from the comments of others, nothing seemed to be amiss. Was it just me that couldn't see the text?
   26. UCCF Posted: June 10, 2010 at 04:30 PM (#3555515)
Has anyone else been having page load problems in the last 24 hours? I'm coming to the site to find a blank page, and it takes sometimes 10 or 15 refreshes to get the page to load at all (and when it does load, the bookmarks bar is only there about half of the time).

This is a new thing that has just popped up the last couple of days. I'm having the same problem in IE and in Chrome, so I don't think it's a browser issue.
   27. Nasty Nate Posted: June 10, 2010 at 04:38 PM (#3555529)
Sometimes in the past week when I have logged on, it just brings me to a white page with a banner advertisement on the left. I have to re-enter the address to get back to the site.

It didn't happen just now when I tried, so maybe it is fixed.
   28. Jim Furtado Posted: June 12, 2010 at 10:03 PM (#3557599)
Eamus and Nasty, are you still experiencing this problem?
   29. Golfing Great Mitch Cumstein Posted: June 12, 2010 at 10:47 PM (#3557617)
What was the decision on the mobile version? I now care.
   30. Jim Furtado Posted: June 14, 2010 at 11:24 AM (#3558554)
At the moment, I'm going through all the site's templates to optimize the site as much as possible, within its current design. As soon as that's done I'll be restructuring and tweaking the design. At that point, I'll work on a mobile version. The major stumbling block for me in building a mobile version is not having a personal smartphone to view the site on. My cell contract is running out this week, however, so that issue will no longer be a problem.
   31. BDC Posted: June 14, 2010 at 12:58 PM (#3558608)
I just logged in and experienced the Eamus/Nasty white page with ad banner. I just go back two pages and end up where I started. As a percentage of the total time I waste here every day, it's negligible :-D
   32. RJ in TO Posted: June 14, 2010 at 01:38 PM (#3558645)
Currently, whenever I go to the main page, I'm getting the "We're doing upgrades to the site, and expect to be down for a while" banner. Everything else seems to work fine.
   33. Pasta-diving Jeter (jmac66) Posted: June 14, 2010 at 10:01 PM (#3559106)
Why is everything doubled on the main newsblog page?
   34. UCCF Posted: June 14, 2010 at 10:02 PM (#3559108)
I'm not still having the problem. However, I'm now getting 2 copies of everything - every story on the front page (and on the individual blog pages) is listed twice, and at the top of a story the introductory information is coming up twice. That all just started happening today, maybe 4 hours ago.

The posts in a thread are only coming up once (so normal). Also, on the bookmarks bar, things are only showing up once (also normal).
   35. Jim Furtado Posted: June 15, 2010 at 12:17 AM (#3559225)
Ryan, are you still seeing the upgrades notice?

Eamus and jmac, the double posts are fixed.
   36. Nasty Nate Posted: June 15, 2010 at 01:08 PM (#3559556)
Eamus and Nasty, are you still experiencing this problem?


yes, off and on.
   37. RJ in TO Posted: June 15, 2010 at 01:32 PM (#3559581)
Ryan, are you still seeing the upgrades notice?

Not anymore. It seems to be gone.
   38. Ray (RDP) Posted: June 15, 2010 at 01:37 PM (#3559584)
Can we have our underline feature back?
   39. The Fallen Reputation of Billy Jo Robidoux Posted: June 15, 2010 at 02:58 PM (#3559695)
I also just got the ad page when I logged in. This was using IE 7.0.
   40. The John Wetland Memorial Death (CoB) Posted: June 15, 2010 at 03:08 PM (#3559708)
yes, off and on.


Me as well, using Firefox.
   41. Jim Furtado Posted: June 16, 2010 at 01:18 PM (#3560688)
OK, so the ad page is displaying when you log in with IE or is it with Firefox too? I did some work on the login action. It should be returning you to the page the login originated from.

Ray, what underline feature are you talking about?
   42. Jolly Old St. Nick Is A Jolly Old St. Crip Posted: June 16, 2010 at 01:29 PM (#3560699)
Ray, what underline feature are you talking about?

The feature that lets us highlight words and underline them. You still have it on the Article Submission page, but you dropped it above the comments box when you added the delete feature.
   43. Pasta-diving Jeter (jmac66) Posted: June 16, 2010 at 01:31 PM (#3560701)
   44. Pasta-diving Jeter (jmac66) Posted: June 16, 2010 at 01:36 PM (#3560702)
<u> underline</u> appears to work in the preview, but not in the finished product, as you see

bold works

italics works

<strike>strike</strike> does not
   45. Ron Johnson Posted: June 16, 2010 at 03:13 PM (#3560808)
#38 I suspect the issue is that the underline tags have been deprecated. (In favor of style sheets)

News to me, but it makes sense that the software Jim is using would drop functionality that is being actively discouraged.
   46. Jolly Old St. Nick Is A Jolly Old St. Crip Posted: June 16, 2010 at 03:21 PM (#3560828)
<u> underline</u> appears to work in the preview, but not in the finished product, as you see

I don't even see the underline feature any more. But del works fine.

EDIT: the above italicized word was supposed to be underlined instead, by using u and /u with brackets. No luck, though.
   47. Pasta-diving Jeter (jmac66) Posted: June 16, 2010 at 03:22 PM (#3560829)
what
what
quote


code 


"del" now is strike
   48. Pasta-diving Jeter (jmac66) Posted: June 16, 2010 at 03:24 PM (#3560833)
I don't even see the underline feature any more.

I did it by hand-- makes everything in italics rather than underlined

I just read on some web page that many sites have removed the "underline" option because it may look like a link and confuse people (??!!)
(you gotta be kidding me)
   49. Mark S. is bored Posted: June 16, 2010 at 03:26 PM (#3560837)
strike

strike with brackets always works for me for strikethrough
   50. Mark S. is bored Posted: June 16, 2010 at 03:31 PM (#3560852)
I just read on some web page that many sites have removed the "underline" option because it may look like a link and confuse people (??!!)
(you gotta be kidding me)


When you have years of underlining being a visual cue for a link, then people will expect that anything underlined is a link.
   51. Jolly Old St. Nick Is A Jolly Old St. Crip Posted: June 16, 2010 at 03:45 PM (#3560881)
I don't even see the underline feature any more.

I did it by hand-- makes everything in italics rather than underlined


That's what I did, too, and with the same results. Maybe it's a Firefox thing. And reading some of the comments here, I'm getting the distinct feeling that we're not all seeing the same menu above our comments boxes.
   52. The John Wetland Memorial Death (CoB) Posted: June 19, 2010 at 05:09 PM (#3564231)
OK, so the ad page is displaying when you log in with IE or is it with Firefox too? I did some work on the login action. It should be returning you to the page the login originated from.


My problem is with Firefox. Just had it take me to an ad page (just the ad on an otherwise blank page, not a click through). Hadn't happened in a while.
   53. The John Wetland Memorial Death (CoB) Posted: June 20, 2010 at 05:10 PM (#3565011)
And again today.
   54. Good cripple hitter Posted: June 20, 2010 at 05:30 PM (#3565025)
I don't know why, but I'm incapable of logging out of my account. If I hit the log out button, it sends me to the page telling me I've successfully logged out, then redirects me to the front page, but I'll still be logged in and refreshing doesn't change that at all. I use firefox, if that helps, and the problem doesn't happen if I use Safari.
   55. Jim Furtado Posted: June 22, 2010 at 12:32 AM (#3566152)
I haven't been able to replicate the Firefox login issue. I've had a few reports, though, so I'm sure it's happening. I'm taking a look at the underlying templates and how ads are embedded.

Cripple hitter, try deleting the site's cookies from your browser. I made some changes to the login script.
   56. Jim Furtado Posted: June 22, 2010 at 11:19 AM (#3566318)
For the people seeing an ad at login, which version of Firefox are you running?
   57. Avoid running at all times.-S. Paige Posted: June 22, 2010 at 01:39 PM (#3566370)
An ad just popped up after I logged on. I'm using safari 4.0.5.
   58. 'zop sympathizes with the wrong ####### people Posted: June 22, 2010 at 01:45 PM (#3566375)
Happened to me just now. Firefox 3.6.3.
   59. RJ in TO Posted: June 23, 2010 at 03:38 PM (#3567715)
For some reason, the Lounge search function is no longer usable. It's returning a "You are not permitted to search" warning, which is not the normal result.
   60. Jim Furtado Posted: June 23, 2010 at 04:00 PM (#3567804)
Ryan, sorry the search will be unavailable for a few days. I have a patch which needs to be applied. It will be back available Friday.

For the people seeing the ad, I've changed the way ads are inserted into the site's pages. If you are still seeing the ads, it would be really helpful to me if you would please let me know your browser type/version and the url for the page you begin the login process.
   61. JJ1986 Posted: June 28, 2010 at 07:20 PM (#3573416)
The newsstand on the front page (http://baseballthinkfactory.org/) is only showing Mariners stories. I know they invented defense, but it's not like they're one of the top 5 organizations in baseball or anything. Is anyone else seeing this?
   62. The Original SJ Posted: July 06, 2010 at 05:23 PM (#3579628)
Has the vertical banner ads destroying the forums been noted?

It seems to be just longer on the mainsite, but on the forums, it makes life difficult in unimaginable ways. Well, probably manageable ways, but still.

Vinay made a very nerdy demonstration video about it.
   63. Spivey Posted: July 15, 2010 at 05:43 PM (#3590588)
I agree 100% with #62, although I think it may be fixed now.

Is there any way that we can update the bookmarks so that the post numbers there are actually accurate. It seems like if two people post at basically the same time, the bookmark incorrectly thinks there was just one post - while in the hot topics it recognizes all posts. This is a mild annoyance for all threads, but in particular the soccer and basketball threads - for both of those threads the bookmark thinks theres ~100 posts less than there really are, so the "Last" hyperlink rarely (or never, in the case of the soccer thread) goes to the last page.

You must be Registered and Logged In to post comments.

 

 

<< Back to main

BBTF Partner

Support BBTF

donate

Thanks to
Jolly Old St. Nick Is A Jolly Old St. Crip
for his generous support.

Bookmarks

You must be logged in to view your Bookmarks.

Syndicate

Page rendered in 0.5154 seconds
48 querie(s) executed